Bug Tracker

Modify

Ticket #11111 (closed bug: invalid)

Opened 2 years ago

Last modified 2 years ago

Table borders disappear in FF with fadeIn()

Reported by: BrianLedsworth Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocking: Blocked by:

Description

Test Case:  http://www.ledsworth.com/jquerytest.html

In FF3, when a table has 'border-collapse: collapse', some borders disappear after fadeIn(). Removing border-collapse and the issue does not appear. Issue does not appear in Chrome or Safari.

Related to ticket #4586.

Reproduced in 1.71. on FF 3.6.25, OSX 10.6.8. Also in 1.6.4.

Change History

comment:1 Changed 2 years ago by BrianLedsworth

Actually, it's a combination of hide() and <td> (I called hide right before fadeIn). Within the hide function, the border goes away right after display=none.

Because I'm hiding a block element, FF has issues with all the borders (display none removes space used by the element).

This ticket can be closed.

I'll change my code to hide an internal <span> and fade it back in.

Brian

comment:2 Changed 2 years ago by rwaldron

  • Status changed from new to closed
  • Resolution set to invalid

Closing per OP's request

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.