Bug Tracker

Ticket #10851 (closed bug: wontfix)

Opened 3 years ago

Last modified 3 years ago

White flash during page load (Firefox)

Reported by: JorisDebonnet Owned by: JorisDebonnet
Priority: low Milestone: None
Component: support Version: 1.6.4
Keywords: Cc:
Blocking: Blocked by:

Description

This is a problem that I actually already experience since 1.6.0. I have looked up about it before, but forgot whether I ended up reporting it; I don't think so.

Pages on a website load quite smoothly in Firefox. You can go from one to the next without any visual 'flashes'. What I mean is: the layout of the previous page just stays there, until the layout of the next page can be drawn. So there's never a 'blank' rendering area. Using jQuery up to 1.5.2 on the page does not change anything about this behavior.

As soon as you include jQuery 1.6.0 or higher however, the page will 'flash' white for a short time (up to a second, probably depending on computer speed). This is very unfortunate if you're browsing through pages on a website that all have the same layout: a lot of continuity is lost.

I realise that not all browsers actually have this; actually, I only found Firefox having this nice feature. But I like it, so it's sad that it's taken away.

Here's a very simple jsFiddle:  http://jsfiddle.net/7cx6f/ (1.5.2: desired behavior in Firefox)  http://jsfiddle.net/7cx6f/1/ (1.6.4: white flashes between reloads)  http://jsfiddle.net/7cx6f/2/ (git: has the same problem)

Change History

comment:1 Changed 3 years ago by timmywil

  • Owner set to JorisDebonnet
  • Priority changed from undecided to low
  • Status changed from new to pending
  • Component changed from unfiled to support

I'm not able to reproduce in any jQuery on FF8. Which version of firefox are you using?

comment:2 Changed 3 years ago by JorisDebonnet

  • Status changed from pending to new

I was using FF7, but just upgraded to FF8. I still have the same issue though. Even when I start it up in Safe Mode (no addons etc), I see the same difference between the first and last version: when I click 'Reload', then the first version stays red, but the second version is white for a short time.

I am using Windows 7, although it would surprise me if this made a difference. So to be sure, I tried it on (a virtual) Windows XP, on Firefox 3.6.23, and I see the same difference there. The page with 1.5.2 stays red while it's loading, the one with 1.6.0+ is white for a moment while it's loading.

comment:3 Changed 3 years ago by sindresorhus

Tested on Mac OSX 10.7.2.

Firefox 8: No white flashes

Chrome 15: White flashes on every jQuery version, but jQuery is probably not the cause:  http://code.google.com/p/chromium/issues/detail?id=1373

comment:4 Changed 3 years ago by sindresorhus

Windows 7 - jQuery 1.7.1: Firefox 3.6: White flashes (though it's gone if the iframe is opened directly) Firefox 8: No white flashes

On Firefox 3.6 this looks like a browser bug, and that jQuery 1.6+ triggers the bug if loaded in an iframe.

Chrome 15 has white flashes even without jQuery.

In my opinion this is a wontfix, since it's pretty obscure and works in the newest Firefox.

Version 0, edited 3 years ago by sindresorhus (next)

comment:5 Changed 3 years ago by sindresorhus

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.