Bug Tracker

Modify

Ticket #10411 (closed bug: worksforme)

Opened 3 years ago

Last modified 3 years ago

JSLint Error when running make

Reported by: alvincrespo Owned by:
Priority: low Milestone: None
Component: build Version: 1.7b1
Keywords: Cc:
Blocking: Blocked by:

Description

I get the followin jslint error when running make:

undefined

Problem at line 547 character 19: Cannot set property 'first' of undefined

node.js:205

throw e; process.nextTick error, or 'error' event on first tick

TypeError: Cannot read property 'reason' of null

at Object.<anonymous> (/Users/alvincrespo/Sites/projects/jquery/build/jslint-check.js:24:13) at Module._compile (module.js:416:26) at Object..js (module.js:434:10) at Module.load (module.js:335:31) at Function._load (module.js:294:12) at Array.<anonymous> (module.js:454:10) at EventEmitter._tickCallback (node.js:197:26)

make: * [lint] Error 1

Here are the steps to reproduce:

hyrule:jquery alvincrespo$ make clean Removing Distribution directory: ./dist Removing built copy of Sizzle hyrule:jquery alvincrespo$ make Results:

Building selector code from Sizzle Building ./dist/jquery.js Minifying jQuery ./dist/jquery.min.js Checking jQuery against JSLint...

undefined

Problem at line 547 character 19: Cannot set property 'first' of undefined

node.js:205

throw e; process.nextTick error, or 'error' event on first tick

TypeError: Cannot read property 'reason' of null

at Object.<anonymous> (/Users/alvincrespo/Sites/projects/jquery/build/jslint-check.js:24:13) at Module._compile (module.js:416:26) at Object..js (module.js:434:10) at Module.load (module.js:335:31) at Function._load (module.js:294:12) at Array.<anonymous> (module.js:454:10) at EventEmitter._tickCallback (node.js:197:26)

make: * [lint] Error 1

jQuery is compiled and created in /dist fine, just this error in terminal.

Change History

comment:1 Changed 3 years ago by timmywil

  • Priority changed from undecided to low
  • Resolution set to worksforme
  • Status changed from new to closed
  • Component changed from unfiled to build

We are unable to reproduce this error during a make. Please make sure you have checked out the latest version of the source and jQuery's submodules (QUnit and Sizzle) and node is properly installed.

comment:2 Changed 3 years ago by alvincrespo

I'm getting this using the following:

node v0.5.8

I've also made sure the latest jquery version was pulled from github.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.