Bug Tracker

Modify

Ticket #10301 (closed bug: invalid)

Opened 3 years ago

Last modified 15 months ago

$.ajax does not always submit data in IE9

Reported by: derril Owned by: derril
Priority: low Milestone: None
Component: ajax Version: 1.6.4rc1
Keywords: Cc:
Blocking: Blocked by:

Description

In IE9, sometimes (not always, I can't reproduce it), $.ajax doesn't submit any data.

I'm using $.ajax a couple of different ways:

$.ajax('/game/start', { type : 'POST', cache : false, data : { unique_str : unique_str, ts : new Date().getTime() } });
$.ajax('/game/register', {
     type : 'POST',
     cache : false,
     data : $form.serialize() + '&ts=' + new Date().getTime(),
     success : function() {
          $((playerNode[0].playerObj.points >= winning_points ? '#finish_won' : '#finish_lose')).fadeOut(function() {
               $('#finish_thanks').fadeIn();
          });
     }
});

On the server, I see the request, but there is no POST or GET data. The URL and everything else seems to be correct.

I added the ts variable in an attempt to make it work, but no luck so far. I also originally hadn't set cache to false.

I've only seen this problem on this site:  http://www.bigshrimpcontest.com/play

I've posted some other details on this SO question:  http://stackoverflow.com/questions/7397676/ajax-not-submitting-data

Change History

comment:1 Changed 3 years ago by addyosmani

  • Owner set to derril
  • Priority changed from undecided to low
  • Status changed from new to pending
  • Component changed from unfiled to ajax

Thanks for taking the time to contribute to the jQuery project! If possible, can you provide a complete reduced test case on jsFiddle to help us assess your ticket? We appreciate you taking the time to submit the links and code snippets provided, however a jsfiddle test will ensure that there are no other factors influencing the issue experienced.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate:  http://jsfiddle.net/FrKyN/

Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 3 years ago by derril

  • Status changed from pending to new

The biggest problem I'm having is that I can't reproduce it and I haven't found anyone else that can either, although it happens around 75 times a day (out of 5000 AJAX requests). Because I can't reproduce it, I don't know how I'd create a jsFiddle test case for it.

Any ideas on how I might start determining what the problem is? I do have all the PHP server vars if that helps at all.

comment:3 Changed 3 years ago by timmywil

  • Status changed from new to pending

I'm not sure this is an issue with jQuery. Have you tried the suggested answer in this SO question?  http://stackoverflow.com/questions/5996702/ajax-problem-in-ie9

comment:4 Changed 3 years ago by derril

  • Status changed from pending to new

I've tried changing the headers on the server response and also adding the unix timestamp to the POST data, but it has had no affect.

comment:5 Changed 3 years ago by timmywil

  • Status changed from new to closed
  • Resolution set to invalid

I'm not sure then. It's hard for us to help without being able to reproduce the issue. If you can provide more specific information about an issue with jQuery, we can reopen this ticket.

comment:6 Changed 15 months ago by nandkishorji@…

Hi,

I am having he same situation, To track the issue .. I added an email notification if there are no POST of GET data posted and i receive around 50 emails a day.

Yes, it seems to be a problem with either IE9 OR jQuery..I also can't reproduce it manually.

Nand

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.