Bug Tracker

Ticket #10222 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

Receiving HTML from Ajax cuasing issues with selecting elements

Reported by: pickalo_us@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.3
Keywords: Cc:
Blocking: Blocked by:

Description

When receiving an HTML page with ajax.

Using $( data ).find( "element" ) returns no results on the elements that are direct children of body. But works fine for all others.

I cannot control the HTML I am receiving, it will always have all basic document nodes, such as HTML, HEAD, and body. I have tested this on IE7, IE8, and Firefox 6.

As a work around I found that I can append it to the page and search it from there. Not sure if this is really a bug, but thought I would try to report it all the same.

Test Case:  http://jsfiddle.net/4mPMJ/

Change History

comment:1 in reply to: ↑ description Changed 3 years ago by pickalo_us@…

I found that using filter() works for the root elements, and I can use find to use CSS selectors from there. Still seems odd to me, that I cannot just select it all using CSS selectors from the get go.

comment:2 Changed 3 years ago by ajpiano

  • Status changed from new to closed
  • Resolution set to duplicate

comment:3 Changed 3 years ago by ajpiano

Duplicate of #3409.

Note: See TracTickets for help on using tickets.