Bug Tracker

Modify

Ticket #10098 (closed bug: fixed)

Opened 3 years ago

Last modified 2 years ago

Encode comment-like Accept headers to avoid mobile carrier mangling

Reported by: dmethvin Owned by: dmethvin
Priority: low Milestone: 1.6.3
Component: ajax Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

It's not our fault but we could easily put a fix in 1.6.3 to prevent the problem -- just encode the slash in the JavaScript string.

 http://www.mysociety.org/2011/08/11/mobile-operators-breaking-content/

Change History

comment:1 Changed 3 years ago by dmethvin

  • Milestone changed from None to 1.6.3

comment:2 Changed 3 years ago by addyosmani

Totally agree with this being fixed. We've seen a number of tickets come through this year about carriers breaking jQuery due to further attempts at minification and I think the comments issue mentioned in the link Dave posted is common to most of them.

comment:3 Changed 3 years ago by timmywil

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to ajax

comment:4 Changed 3 years ago by dmethvin

Here's the pull if we want to put this in:

 https://github.com/jquery/jquery/pull/473

Either that, or close it wontfix and never speak of this again.

comment:5 Changed 3 years ago by dmethvin

  • Owner set to dmethvin
  • Status changed from open to assigned

comment:6 Changed 3 years ago by Dave Methvin

  • Status changed from assigned to closed
  • Resolution set to fixed

Merge pull request #473 from dmethvin/fix-10098-faux-comment

Fixes #10098. Avoid a slashy-starry char sequence to prevent T-Mobile (and other brain-damaged) script compression breaking jQuery.

Changeset: 979dd1cb421a6880463f98842353461a0f1fae6e

comment:7 Changed 3 years ago by dmethvin

#10153 is a duplicate of this ticket.

comment:8 Changed 2 years ago by Markus.Staab

we still encounter a JS Parse error over T-Mobile in Germany, when including jQuery.. doesn't matter if we use 1.6.3, 1.6.4 or the latest release candidate 1.7rc2

Version 0, edited 2 years ago by Markus.Staab (next)

comment:9 Changed 2 years ago by dmethvin

@Markus, If you can identify the cause, for example by capturing the file as downloaded from T-Mobile and comparing it to an unmolested file, that would be helpful. This ticket is closed however; please don't add further comments. Create a new ticket with your findings if it appears that there is something we can do.

comment:10 Changed 2 years ago by thingygeoff

This bug is still happening with certain mobile carriers. You can get round it by using the Google Hosted Code:

 http://code.jquery.com/jquery-1.7.1.min.js

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.