Bug Tracker

Modify

Ticket #10085 (closed bug: invalid)

Opened 3 years ago

Last modified 3 years ago

Jquery selector stop when come to <script> tag in DOM

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: None
Component: misc Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

Recently i spend half day on this issue. here is scenario:

BUG CASE: head: function loadCkEditor(id,config) {

var $editors = $('#'+id); if ($editors.length) {

$editors.each(function() {

var editorID = $(this).attr("id"); var instance = CKEDITOR.instances[editorID]; if (instance) { CKEDITOR.remove(instance); }

$("#"+id).ckeditor(config);

});

}

} dom:

<form> .... <script>loadCkEditor('textarea_id',)</script> <textarea id="textarea_id"></textarea>

result: loadCkEditor function start and return $editors.length = 0

with $.dump i notice that selector come to <script> tag and then stop

Change History

comment:1 Changed 3 years ago by addyosmani

  • Owner set to anonymous
  • Priority changed from undecided to low
  • Status changed from new to pending
  • Component changed from unfiled to misc

I have a feeling this may be closed as invalid, but for the sake of thoroughness, could you kindly put together a reduced test case on jsFiddle.net which doesn't depend on CKEditor or the $.dump plugin?. We need to be able to investigate based on code reproducible without third party dependencies. Thanks!

comment:2 Changed 3 years ago by dmethvin

We definitely need a reduced test case. To get you started, we've created this boilerplate:  http://jsfiddle.net/rwaldron/da3nM/ Open the link and click to "Fork" in the top menu.

comment:3 Changed 3 years ago by trac-o-bot

  • Status changed from pending to closed
  • Resolution set to invalid

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.