Bug Tracker

Ticket #10037 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

jQuery 1.6.2 minified does not load for iOS 4.3.5

Reported by: scandal.uk@… Owned by:
Priority: low Milestone: None
Component: misc Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

Loads fine on iOS 4.1 when JQuery 1.6.2 is minified, but jQuery 1.6.2 will not load at all for iOS 4.3.5 when compressed.

I have also tried compressing it myself with YUICompressor, but I got the exact same issue. I have tested on three iPhones each with different OS versions.

The only way to get it to work is to use the uncompressed version, which adds 130k to the first page load :(

Error message in debug console mentions a parse error in the minified jQuery script.

Change History

comment:1 Changed 3 years ago by Stan Stare

I have uploaded the same website to a secure web server with SSL and the minified jQuery works.

It would appear to be a "mobile provider's proxy" that is messing with the content. In this case, O2 (UK) and T-Mobile (UK), Vodafone works fine.

Setting the cache for "no transforms" did not work, but using SSL is a suitable solution for me.

comment:2 Changed 3 years ago by addyosmani

  • Priority changed from undecided to low
  • Resolution set to duplicate
  • Status changed from new to closed
  • Component changed from unfiled to misc

comment:3 Changed 3 years ago by addyosmani

Duplicate of #9557.

Note: See TracTickets for help on using tickets.