Bug Tracker

Modify

Ticket #10003 (closed bug: fixed)

Opened 3 years ago

Last modified 22 months ago

Regression/BC break from #6963

Reported by: jquery@… Owned by:
Priority: low Milestone: 1.8
Component: selector Version: 1.6.2
Keywords: Cc:
Blocking: Blocked by:

Description

Posting as new bug since no comments were given on the closed bug that was updated with this new information.

There is a bit of a possible regression/BC break in #6963, but I believe it only affects IE. Prior to this change, jQuery could find XML elements within the document; after this change, it cannot. Evidently, XML nodes in IE do not have a parentNode.

While I understand the hazards of going to extensive measures to support IE, it seems like it would deserve more consideration than a Blackberry device.

Please see the following fiddle:

 http://jsfiddle.net/yCrd4/

Change History

comment:1 Changed 3 years ago by timmywil

  • Priority changed from undecided to low
  • Status changed from new to open
  • Version changed from 1.4.2 to 1.6.2
  • Component changed from unfiled to selector
  • Milestone changed from None to 1.next

comment:2 Changed 3 years ago by muzkayise@…

i think its a combination of both, IE9 and JQuery. because when you run  http://jsfiddle.net/fkling/Em2Yq/ in normal IE mode all works fine. as soon you change Document Mode to IE8 it doesn't find the xml element.

comment:3 Changed 3 years ago by anonymous

I am only testing in IE8, which your new fiddle definitely fails on as well.

comment:4 Changed 3 years ago by muzkayise@…

I just did another test using IE8 browser and its not working there as well. so just confirming anonymous test.

created a new fiddler to test:  http://jsfiddle.net/superbDeveloper/Z3CHc/4/

comment:5 Changed 22 months ago by timmywil

  • Status changed from open to closed
  • Resolution set to fixed
  • Milestone changed from 1.next to 1.8

This seems to work now

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.