Bug Tracker

Custom Query (726 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (601 - 700 of 726)

1 2 3 4 5 6 7 8

Status: closed (100 matches)

Ticket Summary Owner Type Priority Component Version
#6647 The height() method doesn't work for iframe window object bug attributes 1.3.2

Reported by allinne, 4 years ago.

Description

$(window.framesmyFrame?).height() creates an error uncaught exception: [Exception... "Could not convert JavaScript argument arg 0 [nsIDOMViewCSS.getComputedStyle]" nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"

#6737 .attr() does not return "undefined" in IE6/7 for an undefined attribute bug low attributes 1.4.2

Reported by Beeper, 4 years ago.

Description

On an input-element i want to check an attribute for existence. so i have something like: $('#id').attr('src') !== undefined

Here is the working example for Jquery 1.3.2:  http://jsbin.com/oveci

Here is the Bug:  http://jsbin.com/oveci/3

It seems to apply only for some HTML-Elements. I tried 'p' and .attr works fine, but for input-elements it returns "" and not "undefined".

#6780 HTML/character entities not handled bug attributes 1.4.2

Reported by kbwood, 4 years ago.

Description

The attr and val functions don't handle/convert HTML and character entities. For example:

$('#input').attr({title: 'søntag'}).val('søntag');

shows this exact text instead of resolving ø to ø.

#6858 IE6 and IE7 textarea val() does not work bug undecided attributes 1.4.2

Reported by olvi, 4 years ago.

Description

Cant update textarea value with val(). In IE8 and all other browsers works fine.

#6931 Setting/Getting Class Attribute Fails in Blackberry 4.7 bug attributes 1.4.2

Reported by john, 4 years ago.

Description

This is due to the fact that the property in element check always fails.

#6932 Blackberry 4.7: .val() on empty option fails bug attributes 1.4.2

Reported by john, 4 years ago.

Description

It will always return .text rather than the .value.

#6938 Blackberry 4.7: .attr("missing") returns "" bug undecided attributes 1.4.2

Reported by john, 4 years ago.

Description

Should return undefined.

#6988 val(['option1', 'option2']) don't work in <select multiple="multiple"> if <option> have attribute value="value" bug undecided attributes 1.4.2

Reported by miwol, 4 years ago.

Description

I found a problem with <select multiple="multiple"> and val(). $('select').val(['option1', 'option2']) work correct with <option>option1</option>. When a write <option value="1">option1</option> then jQuery select nothing. $('select').val([1, 2]) select nothing too.

#7006 .html() on a cloned element returns value of the parent element bug undecided attributes 1.4.2

Reported by Dashu, 4 years ago.

Description

If I clone a tablerow, change its content and then call clone.html(), it returns the inner HTML value of the parent element (the one it was cloned of)

I attached a testcase to reproduce the bug

#7026 Image Attribute Extraction Fails in IE, Works in Firefox bug attributes 1.4.2

Reported by rwadams, 4 years ago.

Description

URL:  http://www.hymntime.com/tch/htm/h/o/template.htm

In Firefox 3.6.9, the above page renders correctly. However, in IE 8.0.7600.16385 (64-bit edition), the width of tables enclosing images is not set to the image width, causing the caption to extend beyond the image's edge (the image in the upper left page corner demonstrates this misbehavior).

The failing code code is at line 39 of hymn2.js, which reads:

var width = $(selector + " img").attr("width");

In Firefox, this correctly extracts the width attribute, but in IE, this code always yields a zero width.

Is this a bug? Is there a workaround to get the width correctly?

#7107 calling $(this).attr('children') returns blank list bug undecided attributes 1.4.2

Reported by longears, 4 years ago.

Description

I have an element: <button class="delete" children="6">delete</button>

I have a click listener on the button: $('button.delete').live('click', deleteTask);

In my deleteTask() method I am unable to access the "children" attribute of my button: $(this).attr('children')

When Output $(this).attr('children') to the console it gives me this: []

This is the same behavior as if I were to try to output an attribute that doesn't exist.

#7117 In the created object returns incorrect data href attribute bug low attributes 1.4.2

Reported by t_e_m_p_v_s, 4 years ago.

Description

Creating an object: a = $('<a href="#' + url + '">' + text + '</a>'); In IE7 (maybe another IE) returns incorrect data of href attribute href = a.attr('href'); Firefox: '#abc' IE7: ' http://host/page#abc'

#7123 <input|checkbox>.val(array-of-values) does not update checked attribute properly if array-of-values are numbers john bug low attributes 1.3.2

Reported by FondDuLac, 4 years ago.

Description

Inside val(), value has been turned into a string if it is a number, but the same check and cast are not performed in the jQuery.InArray(this.value, value) when array[i] is === compared to value.

#7125 Source attribute in ie7 bug undecided attributes 1.4.2

Reported by avirto, 4 years ago.

Description

Could you tell me if there any way to use function hover with source attribute change?

$('.artur').hover(function(){ $(this).attr('src','img/arturOn.png'); }, function(){ $(this).attr('src','img/artur.png'); });

This works in almost all browser but not in IE7. I tried to put the long URL but it still doesn't work. Thank you for your help. I hope this is a correct place to ask such question.

#2960 jQuery sends wrong content type to server on ajax post requests if data is {} bug major ajax 1.2.5

Reported by barushev, 6 years ago.

Description

Small testcase:

$.post('/index')

no Content-Type and Content-Length headers
$.post('/index', null)

no Content-Type and Content-Length headers
$.post('/index', {'test': 'test'})

Content-Type	application/x-www-form-urlencoded
Content-Length	9
$.post('/index', {})

Content-Length	0
Content-Type	application/xml
$.post('/index', function () {})

Content-Length	0
Content-Type	application/xml

It's wrong Content-type application/xml in last two exaples.

---

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080419 Ubuntu/8.04 (hardy) Firefox/2.0.0.14

#3240 Serialize will submit disabled select options dmethvin bug major ajax 1.4.2

Reported by danielnashnz, 6 years ago.

Description

If you have a selected option from an HTML form select dropdown that is _disabled_ (i.e. by the option having disabled="disabled" attribute), the $.serialize() method will still encode its value. According to the HTML 4.01 spec a disabled field can never be 'successful' (that is have it's value sent). Ref:  http://www.w3.org/TR/html401/interact/forms.html#successful-controls

e.g. from this HTML form block, only the value "mA" should succeed, but serialize also serializes "mC"

<select id="03_multi_select_option_disabled" name="03_multi_select_option_disabled" multiple="multiple" size="4">
  <option selected="selected" value="mA">multiselect A</option>
  <option value="mB">multiselect B</option>
  <option selected="selected" value="mC_disabled" disabled="true">multiselect C disabled</option>
  <option value="mD">multiselect D</option>
</select>
#3808 $().load() fails 404 if there is a hash in the url bug low ajax 1.2.6

Reported by pixeline, 6 years ago.

Description

NB: both 1.2.6 and 1.3 beta 2 are concerned with this bug.

Internet explorer fails to load a url that contains a hash (result: 404).

See:  http://pixeline.be/experiments/jquerybeta/test2.html

It does not work in 1.2.6 either.

In my code, i solved it like this:

var href = $(this).attr('href').replace(/#.*/, "");

#4044 $.ajax POST in Firefox fails with a null data parameter garrett bug major ajax 1.3.1

Reported by garrett, 6 years ago.

Description

Firefox has a bug where it does not send a Content-Length of 0 in a post when the post's body is omitted. Ordinarily, this works well with popular webservers... however, Squid (and possibly other proxies) complain and refuse to actually post.

Simply setting a Content-Length does not solve this issue; Firefox does not transmit custom Content-Length headers. The solution is to send an empty string instead of null. This makes Firefox send a Content-Length, and as a result, Squid is happy.

I am attaching patches for both jQuery 1.2.6 and 1.3.1 which fix this issue.

#4855 Wrong script encoding in IE6/7 dmethvin bug minor ajax 1.4.2

Reported by twirl, 5 years ago.

Description

Ajax.js, line 255

script.src = s.url; if (s.scriptCharset)

script.charset = s.scriptCharset;

If script is already in cache, IE6/7 takes it immediately when src is set. If there is no charset given, IE assumes that script encoding is system. Src should be set AFTER charset.

#4987 wrong url building in case we have a hash bug minor ajax 1.4.2

Reported by Shahen Shabunc, 5 years ago.

Description

if we have a hash in the url we want to pass to $.get, get parrams we'll be serialized incorrectly:

document.location.hash = "test"; jQuery.get(document.location.href,{wrong_get:"shouldn't_be_there"});

 http://dev.jquery.com/report#test?wrong_get=shouldn%27t_be_there

#5123 Chrome $.ajax doesn't work without data option bug minor ajax 1.4.2

Reported by coxmatthew, 5 years ago.

Description

Found that my ajax processing wasn't working in chrome. Although the same request using $.post() worked fine.

Workaround:

adding an empty data attribute (data: "") seems to work around this issue.

Details:

----------------------------

Succeeds

----------------------------

$.post("test.php",

function(data){

alert("Test results: " + data);

}, "text");

--------------------------------

Throws error in chrome (ver 2.0.172.39)

----------------------------------

jQuery.ajax({

type: "POST", url: "test.php", success: function(data){

alert("Test results: " + data);

},

error: function (XMLHttpRequest, textStatus, errorThrown) {

alert("Error with ajax Function: "+ textStatus+" "+errorThrown); },

dataType: "text"

});

----------------------------

Succeeds

----------------------------

jQuery.ajax({

type: "POST", url: "test.php", data: "", success: function(data){

alert("Test results: " + data);

},

error: function (XMLHttpRequest, textStatus, errorThrown) {

alert("Error with ajax Function: "+ textStatus+" "+errorThrown); },

dataType: "text"

});

#5383 if jsonp not crossdomain, the complete handler will trigger twice bug high ajax 1.4.2

Reported by asfman, 5 years ago.

Description

the first trigger in onreadystatechange the second trigger in window[jsonp]

it can be solved the same as success handler: if ( !jsonp )

success();

if ( !jsonp )

complete();

#6060 Aborted AJAX requests are considered as successfull in 1.4 bug ajax 1.4.2

Reported by smira, 5 years ago.

Description

It looks like in changeset [6432] (ticket #4764) while fixing 304 error response for Opera handling of aborted XMLHTTPRequests has been broken.

The suspicious change is change to httpSuccess handler for $.ajax, treating status of zero as successful. For XMLHTTPRequests status of zero means aborted requests.

This is the patch that "fixes" this issue:

Index: public/javascripts/jquery-1.4.js
===================================================================
--- public/javascripts/jquery-1.4.js	(revision 22310)
+++ public/javascripts/jquery-1.4.js	(working copy)
@@ -%ld,%ld +%ld,%ld @@
 			return !xhr.status && location.protocol === "file:" ||
 				// Opera returns 0 when status is 304
 				( xhr.status >= 200 && xhr.status < 300 ) ||
-				xhr.status === 304 || xhr.status === 1223 || xhr.status === 0;
+				xhr.status === 304 || xhr.status === 1223;
 		} catch(e) {}
 
 		return false;

Maybe there's a better way to fix that including mentioned Opera bug

#6186 $.post silent error in firefox bug ajax 1.4.2

Reported by cinemaguy, 5 years ago.

Description

$.post seems to have a silent error in firefox. i have confirmed that this works in Safari, Chrome, and Camino, but in Firefox and it reports back a successful message but does not continue onto the next ajax call. I rolled back to jquery 1.3.2 and everything started working fine.

I've attached the offending code. Here is what happens:

The first ajax call writes to a json file on my server. Works fine. Next ajax call creates a thumbnail of the image being uploaded. Works fine. Reports back success. Image is created. (This is where firefox receives the success msg but will not continue on to the next ajax call) Next ajax call updates the screen with the thumbnail.

Let me know if you have any questions. Thanks!

#6214 1.4.2 AJAX .abort script error in IE bug ajax 1.4.2

Reported by itbeyond, 5 years ago.

Description

Request .abort() in IE seems to throw a script error which it did not do in 1.3.2. The code below:

var p5k_aid = null; $jq(document).ready(function() { $jq('#p5k_pib_b_dl a').mouseover(function() { if (p5k_aid) {p5k_aid.abort()} p5k_aid = $jq.get(BaseURL + '/Utilities/Ajax/getKeyword.aspx?id=W' + $jq(this).attr('id').replace('p5k_', ), function(html) { $jq('#p5k').html(html);}); }).first().mouseover(); });

Works perfectly in Firefox (firebug shows the abort) but in IE throws a script error: Object doesn't support this property or method - Line: 170 - Char: 489. Coupled with this the abort itself does not trigger so the ajax command processes to the end (in my case can cause out of sequence responses)

I have just started using 1.4.2 and this is the first little issue I have found. Any help or ideas.

#6240 multiple "simultaneous" $.ajax requests don't all complete in FF 3.5.8 bug undecided ajax 1.4.2

Reported by squeat, 5 years ago.

Description

When I time it so that I submit an ajax request right after another has started (but not completed), the first request seems to finish up as expected but the 2nd request never calls the success, error, or complete callbacks. Firefox shows that the data was received as expected. This is using FF 3.5.8 on all 1.4.x versions of jQuery (up to 1.4.2). It works as expected with 1.3.2. Both of my requests are using dataType of 'json'.

#6241 $.ajax calls the success callback in FF 3.5.8 for failed cross-origin requests. bug undecided ajax 1.4.2

Reported by jambo, 5 years ago.

Description

In Firefox 3.5.8, when I attempt an illegal cross-origin request, the "success" callback is still called. Firefox's response to an illegal cross-origin request is now to blank xhr.responseText and set xhr.status to zero, even though xhr.readyState === 4.

This should be reproducable by simply attempting a cross-origin request to a domain that does not support it, for example with the following code:

$.ajax({

url : " http://www.example.com/", success : function() {

alert( "Oops!" );

}

});

#6248 ajax calls success twice when server is unavailable kgustine bug low ajax 1.4.2

Reported by kgustine, 5 years ago.

Description

jQuery: 1.4.2; Firefox: 3.5.8

I have found that the following script calls success twice when the web server is turned off. This is proven by resetting testCount when the function is called, but incrementing it in success. If you run this in firefox and turn off the server, the alert box will first say 1, then 2.

This only happens the first time ajax is called after the server is turned off. It is not necessary to point ajax to a vaild page.

This is similar to bug #5968 and I'm sure is closely related.

This was discovered because I was clearing and setting Timeouts and Intervals inside the Success function. I was getting thousands of ghost intervals after a short period.

<script type="text/javascript" src="jquery-1.4.2.js"></script>
<script>
var testCount;
function callAjax()
{
  testCount = 1;
  $.ajax({
    url: "http://localhost/blah.php",
    success: function( msg ) {
      alert( testCount++ );	
    }
  });
}
callAjax();
setInterval( "callAjax()" , 5000 );
</script>
#6273 .getJSON does not work for extra params. (?undefined=undefined) bug low ajax 1.4.2

Reported by jq_johan, 5 years ago.

Description

<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN"> <html>

<head>

<script type="text/javascript" src="jquery-1.4.2.js"></script>

</head> <body>

<script type="text/javascript">

var aoData = new Array(); aoData.push({a:"1"}); $.getJSON( "jsonpage.html", aoData, function (json) {});

</script>

</body>

</html>

The string sent to the server is:

 http://localhost/jqueryjsontest/jsonpage.html?undefined=undefined

The parameters are sent as undefined.

#6284 Return json not working in $. ajax bug ajax 1.4.2

Reported by dioubernardo, 5 years ago.

Description

javascript code: $.post("url ...", "parametros=1", function(d){

alert(d)

}, 'json');

php return: {p:"",r:"<tr><td>cmsMenu</td><td><i class=\"ico i8\"></i> CMS - Menu Base</td><td class=\"op\"><a class=\"ico i1\" href=\"/saite/cms/menus/editar/1\"></a><a class=\"ico i2\" href=\"/saite/cms/menus/delete/1\"></a></td></tr><tr><td>cmsConteudos</td><td><i class=\"ico i8\"></i> CMS - Menu Conteúdos</td><td class=\"op\"><a class=\"ico i1\" href=\"/saite/cms/menus/editar/2\"></a><a class=\"ico i2\" href=\"/saite/cms/menus/delete/2\"></a></td></tr>"}

the alert is not called. Before upgrading to jquery 1.4 worked.

sorry for my English if in code javascript replace 'json' by 'text' then the alert is show.

#6294 jQuery1.4.2 ajax bug bug undecided ajax 1.4.2

Reported by zhanghuihua, 5 years ago.

Description

jQuery.ajax({

type: "POST", url: url, data: data, success: callback, dataType: type

});

if dataType is "json", then connot call callback function. default dataType is OK.

#6295 jquery.load() not work in chrome bug ajax 1.4.2

Reported by yongjiebai, 5 years ago.

Description

I test my script in IE8 , FireFox3.5 both of them work ,but in chrome. Just as the script just as $('#myDiv').load('aa.html'); And I test some versions of JQuery(1.3.2 , 1.4.2), I got the same result. Something I did wrongly or JQuery Bug?How can I fix it? Thank you.

#6298 IE7,IE8 throw exception on new window.XMLHttpRequest(); john bug high ajax 1.4.2

Reported by name5566, 5 years ago.

Description

Microsoft failed to properly implement the XMLHttpRequest in IE7 and IE8.

Test Case: <!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN" " http://www.w3.org/TR/html4/loose.dtd"> <html>

<head>

<script src="js/jquery/jquery-1.4.2.js" type="text/javascript" charset="utf-8"></script> <meta http-equiv="content-type" content="text/html; charset=utf-8"> <title>index.html</title> <script type="text/javascript" charset="utf-8">

$(function() {

$('a').click(function() {

$('div').load('register.html'); return false;

});

});

</script>

</head> <body>

<div></div> <a href="register.html">Here</a>

</body>

</html>

Open the IE8 or IE7 and then click the link(register.html) if you open the page, don't reload the page, and click the link at the first time.

IE7 window.XMLHttpRequest will throw a exception: Permission Denied IE8 window.XMLHttpRequest will throw a exception: Object don't support this property or method

if you reload the page, and click, on exception throw.

I try to fix it: xhr:function() { return window.ActiveXObject ? new ActiveXObject("Microsoft.XMLHTTP") : new XMLHttpRequest(); },

it be well.

#6299 jQuery 1.4.2 breaks AJAX success/failure behaviour bug undecided ajax 1.4.2

Reported by damian.biollo, 5 years ago.

Description

There is a small change to the behaviour of httpSuccess() which breaks the behaviour of AJAX in Firefox.

The breakage is in the scenario when a user clicks a link while an AJAX request is being processed. In Firefox, clicking a link to navigate will immediately cancel all outstanding HTTP requests. (Check Firebug Console to see the behaviour).

In previous versions of jQuery, this would result in a "failure" - the failure ajax handler would be called.

In 1.4.2 this results in the "success" handler being called, which seems quite wrong.

The bug is due to adding a condition of "or xhr.status == 0" to the httpSuccess function.

#6314 Version 1.4.1 & 1.4.2 crash customizerd IE 7 when "native XMLHTTP support" is disabled bug undecided ajax 1.4.2

Reported by pinh3ad, 5 years ago.

Description

After doing a lot of testing and research to determine the cause of an IE7 crash, I have figured out that when a version of IE7 has been distributed using the Internet Explorer Administration toolkit the "Enable XMLHTTP Requests" option is disabled by default. This disabling will cause 1.4.1 and 1.4.2 (not tested with 1.4) release of Jquery to crash IE. At this point the task must be killed in windows to recover.

You can manually go to a ie7 instance and disable this feature under advanced option -> security, which will allow you to reproduce the problem. Another way to determine if the browser has been custoomized is to look at the IE version infor under help. The customized version is indicated with a "CO" at the end of the version. The specific versions this was tested under is 7.0.5370.13CO and .11

#6317 Stringlenght bug ajax 1.3.2

Reported by KrisTemmerman, 5 years ago.

Description

JQuery doesn't send parameters of wich the length of the parameter name is smaller then 6 characters.

e.g

data:{'fAEmail':email,'fAMessage':message,'fAName':name},

JQuery doesn't send the fAName parameter.q

Kris Temmerman

#6323 Ajax get/post does not complete in Google Chrome on Linux bug ajax 1.4.2

Reported by joe_archer, 5 years ago.

Description

I am using $.get to make a simple request to a PHP script which responds with JSON (using the PECL uploadprogress extension to create a progressbar)

In firefox/IE (windows and Linux) this works without issue, however in Google Chrome on Linux, the ajax request never completes (firebug shows the request as active, whereas it completes with as http 200 in firefox)

#6333 $.get() bug bug undecided ajax 1.4.2

Reported by rossen, 5 years ago.

Description

I only get this bug in IE8. This is the current version of jQuery (1.4.2), below is a stack trace:

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2) Timestamp: Mon, 22 Mar 2010 07:28:18 UTC

Message: Object doesn't support this property or method Line: 123 Char: 183 Code: 0 URI:  http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js

If you need further information to investigate the error feel free to email me :)

Br. Rossen

#6334 AJAX Loads in IE7 but not IE8 bug ajax 1.4.2

Reported by Gaias Enigma, 5 years ago.

Description

On lines 4987-4999 IE8 try's to load

"return new window.XMLHttpRequest();" instead of "return new window.ActiveXObject("Microsoft.XMLHTTP");"

Note in IE5-IE7 Works fine

#6343 XMLHttpRequest Leak in IE 7 bug undecided ajax 1.4.2

Reported by Daazku, 5 years ago.

Description

The default behavior of jQuery is to create an XMLHttpRequest if the browser support it. But in IE 7 (don't know for other versions) XMLHttpRequest don't release resources until you refresh the page or navigate away.

We should handle that and supply ActiveXObject by default for IE.

#6346 conflict between jQuery 1.4 and Sarissa doug bug low ajax 1.4.2

Reported by doug, 5 years ago.

Description

There's a conflict between jQuery 1.4 and Sarissa.

Similar reports:

 https://jira.jboss.org/jira/browse/RF-8282

 http://code.google.com/p/google-web-toolkit/issues/detail?id=3608

#6349 Ajax callback not called while firebug opened bug undecided ajax 1.4.2

Reported by fishcn, 5 years ago.

Description

Ajax callback not called while firebug opened and switched to network panel. following code works all correctly in jquery 1.3.2: $.post("test.aspx",{},function(info){

....

},"json");

With 1.4.2, if network panel in firebug opened, the callback will never executed. (It seems that firebug has captured the request and blocked it -- but if replace jquery from 1.4.2 to 1.3.2 you'll find this problem disappeared.)

#6352 cache is not being false by default with datatype === "script" bug undecided ajax 1.4.2

Reported by nsabena, 5 years ago.

Description

In jQuery 1.3.2, there was this test:

if ( s.dataType === "script" && s.cache == null ) {

s.cache = false;

}

which correctly set the s.cache value to false if s.cache was null OR undefined. In jQuery 1.4.2 this was changed to:

if ( s.dataType === "script" && s.cache === null ) {

s.cache = false;

}

(using exact equality) which no longer works when s.cache is undefined (most of the times). I think it should be reverted to the "==" comparer (s.cache == null).

#6354 http to https transition by ajax bug ajax 1.3.2

Reported by krishanu, 5 years ago.

Description

I have entered into a page using  http://myIpAddress:9081/AjaxApplication/home.do?method=getHome. In this page i have a dropdown & on change of dropdown value i am firing an ajax call. $.ajax({

url:"http://myIpAddress:9081/AjaxApplication/home.do", data: {"method" : "getMakeList", "year" : year}, dataType: "json", type: "POST", async: false, success:function(json){

populateMakeDropdown(json.makeDropdown); }

});

This is working fine....But when i changed "http" to "https", it is not making the call... Though it is working fine in IE6 but not in Mozila3.5...

There were some solution which i found at internet that making data as blank{}, but it is also not working... Please help with some fruitful solutiuon....

Thanks in advance...

#6378 An error is thrown if the returned document is expected to be valid XML but it is not. bug undecided ajax 1.4.2

Reported by tw2080, 5 years ago.

Description

Additinal check is required to chatch if data.documentElement == null before data.documentElement.nodeName is checked.

Function httpData, line 5351 should be: if ( xml && data.documentElement && data.documentElement.nodeName === "parsererror" ) {

#6388 $.getJSON memory leak with JSONP even on success tarad10 bug undecided ajax 1.4.2

Reported by tarad10, 5 years ago.

Description

I am running $.getJSON inside an interval every 10 seconds. The script is polling the twitter search JSON API. It is grabbing the first 50 tweets based on a search query and dumping them into a div with the prepend() function.

The code works fine, but the $.getJSON function is leaking. I have spent a great deal of time trying to figure out why, but it seems like something is fundamentally wrong with the garbage collection.

My searching lead me to this site:  http://neil.fraser.name/news/2009/07/27/. There is a mention of manually going into the script element and deleting all of the properties to force deallocation. I have implemented this into the uncompressed jQuery 1.4.2 include by adding these three lines directly after line 5027 (head.removeChild( script )):

for(var prop in script) { deletes script[prop]; }

This seems to help in that I can see at least some memory get freed up (before it was never going down), but it has not fixed the problem entirely. Perhaps I have implemented it in the wrong place, because it does not seem to delete all the properties.

I am not sure if this is due to running it within an interval or some other issue with my code, but I can't seem to figure out why it is leaking. I appreciate any help you can offer.

#6389 .ajaxError does not fire in 1.4.2 bug undecided ajax 1.4.2

Reported by rocketbob, 5 years ago.

Description

I have exception handling on the server which raises a 500 error. .ajaxError no longer fires with 1.4.2, but works fine in 1.3.2.

#6399 Jsonp ajax request errors on success callback when doing a redirect bug undecided ajax 1.4.2

Reported by cblaze22, 5 years ago.

Description

There is a bug in the jquery ajax jsonp request on success when doing a redirect from http to https. The error happens on this line.

window[ jsonp ] = undefined;

I am making a https ajax call and doing a redirect in the success page with http.

window.location = window.location.toString().replace(' https://', ' http://') + '?success';

The jquery success method finishes up, but still tries to finish by trying to access the window in the dom, but can't because it was originally from an https page, and now its on a http page.

#6424 .load callback function bug bug ajax 1.3.2

Reported by misssprite, 5 years ago.

Description

I wrote : $('#adiv').load('url.html',function(){

alert($('#aspan').text()); aspan is a span elem in the url.html

}); finally i found i can't select any element in the url.html in the callback function so i had to use $.ajax, and the $('#adiv').html(...) function. it seems a bug with jquery the document tree hasn't been constructed when the callback func is called

#6440 complete() not called with ajax request bug undecided ajax 1.4.2

Reported by danielsomerfield, 5 years ago.

Description

Using the $.ajax() function, I am making a call to code which returns a 302 status code. When I hit the given url via a POST, none of the callbacks are triggered. I have call backs for complete, success and error, and the whole thing wrapped in a try catch just to be sure. It just silently succeeds (so to speak) without calling a single callback. I have even added a global complete--also not called.

There are two ways I can make the callbacks work: use jquery 1.3.2--then it works fine, or step through it with firebug. I step through it, it works fine.

Sadly, due the strange nature of the bug, I don't have a good repro. My simple test cases doesn't repro--I will continue to search for one.

My call is triggered by a button click and looks like this: $.ajax({

url: "url_to_servlet" type: "post", data: {

name: "name", url: "url", onClickAction: "action"

}, success: function(data, status, request) {

alert("success"); NEVER CALLED

}, error: function() {

alert("error"); NEVER CALLED

}, complete: function() {

alert("complete"); NEVER CALLED

}

});

Also: this is under FF3.6 on OS X 10.5.8. Works like a charm on Safari.

The best I can do for right now for a repro is put the code up somewhere on a test server.

#6451 local jsonp requests cause ajax 'active' counter to decrement twice bug ajax 1.4.2

Reported by malsup, 5 years ago.

Description

This can be seen by inspecting the active counter at the end of a unit test run. active == -12. Tested against current 1.4.3 dev code. Submitting patch via github.

#6453 Dynamically adding a JS file(s) not caching in Opera bug undecided ajax 1.4.2

Reported by GrandMother, 5 years ago.

Description

even if 'cache' option is true. every generation of page - loading from server (viewing apache logs)

#6463 AJAX IE ERROR "OBJECT DOESN'T SUPPORT THIS PROPERTY OR METHOD bug ajax 1.4.2

Reported by twenzel, 5 years ago.

Description

Here are the steps to reproduce the problem:

#6471 XHR request sometimes throw an error when it is aborted in IE8 bug undecided ajax 1.4.2

Reported by mefcorvi, 5 years ago.

Description

In some cases "abort" method in IE8 (8.0.6001.18702IC) invokes onreadystatechange with readyState = 4.

I've fixed it in my code. I replaced

try {
  var oldAbort = xhr.abort;
  xhr.abort = function() {
    if ( xhr ) {
      oldAbort.call( xhr );
    }
    
    onreadystatechange( "abort" );
  };
} catch(e) { }

to

try {
  var oldAbort = xhr.abort;
  xhr.abort = function() {
    if ( xhr ) {
      xhr.onreadystatechange = jQuery.noop;
      oldAbort.call( xhr );
    }
    
    onreadystatechange( "abort" );
  };
} catch(e) { }
#6480 Create XHR object sometimes fails on IE7/8 bug ajax 1.4.2

Reported by Mac_J, 5 years ago.

Description

In some case, it dosn't work when you open web page at first. Must refresh the page.

I modified code at line 4952. It's work.

xhr: function() {

try {

return new ActiveXObject("Msxml2.XMLHTTP");

} catch (e) {

try {

return new ActiveXObject("Microsoft.XMLHTTP");

} catch (e2) {}

} if (!xmlHttp && typeof XMLHttpRequest != 'undefined')

return new XMLHttpRequest();

},

#6498 XHR abort() method not working in IE7. laurensonyourscreen bug high ajax 1.4.2

Reported by laurensonyourscreen, 5 years ago.

Description

When you call the abort() method on a jQuery XHR object. IE7 will raise an error. The error IE7 (version 7.0.6001.18000 to be exact) is giving is:

"Object doesn't support this property or method (line 5233)"

Looking into the jQuery source, it seems to fail on this peace of code:

" Override the abort handler, if we can (IE doesn't allow it, but that's OK) Opera doesn't fire onreadystatechange at all on abort try {

var oldAbort = xhr.abort; xhr.abort = function() {

if ( xhr ) {

oldAbort.call( xhr ); <-- here!

}

onreadystatechange( "abort" );

};

} catch(e) {console.log(e) } "

To reproduce this in IE7, I used this: " var xhr = $.ajax({

url: ' http://samedomain.com/', dataType: 'json'

});

xhr.abort(); "

I know the issue does not raise in Firefox 3.6.3. But I haven't tested it in other browsers.

#6517 Sending ajax request with bookmark(#) in IE7 bug undecided ajax 1.4.2

Reported by kievBug, 5 years ago.

Description

The problem is that bookmark should not be sent to the server when I'm doing ajax requests, because normally it is not sent to the server side in regural requests(not ajax). It works in FF, but doesn't work on IE. It is definately an IE problem but I think it may also be fixed in jQuery.

Thanks.

#6518 .ajax() ifModified option -- behaviour changed in v1.4.2 bug undecided ajax 1.4.2

Reported by rsinton, 5 years ago.

Description

As described by jQuery forum user alxblog, the ifModified option seems to have stopped working between v1.3.2 and v1.4.2.

Forum posting with good sample code:  http://forum.jquery.com/topic/jquery-1-3-2-update-to-1-4-2-ifmodified-option-doesn-t-still-work

The sample code works as expected in v1.3.2, delivering "notmodified" as the textStatus parameter to the .ajax() call's error function. This matches the behaviour described in the documentation for .ajax().

In v1.4.2, however, the success function is called every time.

I can see that the relevant jQuery code for this functionality has changed quite a bit between those versions. Looks like the problem is here:

Make sure that the request was successful or notmodified

if ( status === "success"
status === "notmodified" ) {

JSONP handles its own success callback if ( !jsonp ) {

success();

}

} else {

jQuery.handleError(s, xhr, status, errMsg);

}

i.e. "notmodified" is now being treated as a success rather than an error.

#6551 jsonp without a defined callback name does not set the Accept headers properly bug undecided ajax 1.4.2

Reported by joeshred, 5 years ago.

Description

Try using the $.getJSON(...) or $.ajax(... ,dataType: 'jsonp', ... ) without setting the callback=<x> (the <x> part), and the Accept Header is set to */*, instead of "application/json...".

Reproducable by this (Note that this serverside code does not yet handle the callback parameter, but am experimenting to allow cross domain script calls to our API).

This loads incorrect Accept Header (even though JQuery will generate a name for the callback method):

$.getJSON(" https://api.globalgiving.org/api/public/projectservice/themes?api_key=e10c5e8e-730f-41c0-9b07-0983c94160a4&callback=?",

function(data){ alert("The Data is:"+data);});

This loads correct Accept header (by defining "callback=foo")

$.getJSON(" https://api.globalgiving.org/api/public/projectservice/themes?api_key=e10c5e8e-730f-41c0-9b07-0983c94160a4&callback=foo",

function(data){ alert("The Data is:"+data);});

I have similar issues using the dataType: 'jsonp' and jsonpCallback: param's in the .ajax(...) call.

#6560 Problem with getJSON bug ajax 1.4.2

Reported by gerardogup, 5 years ago.

Description

I have an script working perfectly with verion 1.3.2. This script uses getJSON function. Nevertheless, when I upgrade to 1.4.1 or 1.4.2, it does not work. Callback function never fires and when i track the error using $.ajax function, there is a parser error. This error says that i have an invalid JSON. This is not true because using 1.3.2 works fine. JSON structure has the next format... { variable1 : 'value1', variable2 : 'value2', variable3 : 'value3' } Thank you for your support. Gerardo

#6567 [XML-ATOM Feed] request with Win 7 / IE 8 egokamoto bug low ajax 1.4.2

Reported by egokamoto, 5 years ago.

Description

When I do a request in 'xml' mode with the code:


options = jQuery.extend({

url: null, data: null, success: null

}, options);

if(options.url) {

$.ajax({

type: 'GET', url: options.url, data: options.data, dataType: 'xml', success: function(xml) {

var feed = new JFeed(xml); if(jQuery.isFunction(options.success)) options.success(feed);

}

});

}


using a ATOM feed url, the IE8 cannot parse it, then, I added the following code at line 5346:


httpData: function( xhr, type, s ) {

var ct = xhr.getResponseHeader("content-type")
"",
xml = type === "xml"
!type && ct.indexOf("xml") >= 0,

data = xml ? xhr.responseXML : xhr.responseText;

>>>> My changes if (xml && !data.documentElement && xhr.responseText)

data.loadXML(xhr.responseText);

<<<< ended my changes

if ( xml && data.documentElement.nodeName === "parsererror" ) {

jQuery.error( "parsererror" );

}


#6573 Error running at Firefox. bug undecided ajax 1.4.2

Reported by kahhiung, 5 years ago.

Description

I tested the jquery over the IE. It is working fine. But, when I run the same pieces of code at Firefox, then it will return an error message to me:

input is null if (input.d.IsError == true) {

The code are as follow:

$("a[class=edit_link]").click(function () {

var ID = $(this).attr("id");

var dataString = "\"ID\":\"" + ID + "\""

$.ajax({

type: "POST", url: " http://DMSDeveloper/eFICPSConverted/testLookupWebMethod.aspx/LoadRecordDetail", data: "{" + dataString + "}", contentType: "application/json; charset=utf-8", dataType: "json", success: function (input) {

if (input.d.IsError == true) {

alert(input.d.ErrMessage);

} else {

$("input[type=text][id=txtName]").val(input.d.Name); $("input[type=text][id=txtContact]").val(input.d.Contact);

$("div[id=TestLookup.aspx.Lookup]").hide(); $("div[id=TestLookup.aspx.Detail]").show();

$("input[type=text][id=txtID]").val(ID); $("input[type=text][id=txtType]").val("E");

$('label[class=error]').hide();

}

}, error: AjaxFailed

})

});

#6586 JQuery 1.4.2 + IE + $.ajax bug ajax 1.4.2

Reported by scottchiefbaker, 5 years ago.

Description

I have created a test case for a reproducible $.ajax bug with IE and JQuery 1.4.2. See the test case below for more information. I have confirmed this bug is present in IE7 and IE8.

 http://www.perturb.org/tmp/ie-ajax.html

#6589 jQuery.ajax Browser History Enhancement enhancement undecided ajax 1.4.2

Reported by rgrwkmn, 5 years ago.

Description

I know there are plugins that cover this functionality, but why include another js file and write extra code? Why not build browser history management into the standard ajax method?

You could add a couple properties into the ajax method:

updateHistory - Boolean, defaults to false

historyHash - String, the hash to add to the url

There would also need to be a history init method that would load a url if a location hash exists on page load as well as loads triggered on browser back/forward buttons obviously.

This would take care of very simple ajax loads. The tricky part is keeping the flexibility that a history plugin has, since the developer may use location hashes that don't correspond directly to the url being loaded and also could require post or get data.

#6602 Chrome can't do: $(...).load(url, title); bug ajax 1.4.2

Reported by matrym, 4 years ago.

Description

The solution was resolved to my satisfaction on stack overflow. I recommend either updating the documentation to explain the limitations, or adjusting the method to be cross-browser:

 http://stackoverflow.com/questions/2911930/jquery-cant-load-the-head-title-in-chrome

TLDR:

$.get(" http://fiddle.jshell.net/",

function(response){

alert((/<title>(.*?)<\/title>/m).exec(response)[1]);

});​

#6612 Support additional request types for caldav feature undecided ajax 1.4.2

Reported by haraldk, 4 years ago.

Description

Caldav uses, for example, REPORT instead of PUT. In line 5252 of jquery-1.4.2.js we have

xhr.send( type === "POST"
type === "PUT" type === "DELETE" ? s.data : null )

It would be cool if this were configurable and would rather read something like

xhr.send( s.sendData[type] ? s.data : null )

where s.sendData is a map from request types to true or false.

#6620 ajax method does not load XML on IE bug undecided ajax 1.4.2

Reported by philk, 4 years ago.

Description

The following steps are required to make ajax work on IE:  http://rationalogic.com/development/jquery-ajax-and-internet-explorer/

This should clearly be handled inside the library instead of everybody building his own fix. IE will bail out in ajax.httpData at the line: if ( xml && data.documentElement.nodeName === "parsererror" ) {

jQuery.error( "parsererror" );

} In case of an IE browser it should apply the steps outlined in the blogpost automatically.

#6631 $.getJSON dont work in jquery-1.4.2 bug ajax 1.4.2

Reported by jocor87, 4 years ago.

Description

I am working with jquery-1.3.2 + json with the function $.getJSON and all is perfect.

But when i change to jquery-1.4.2 the function $.getJSON don`t work.

#6633 exception in ajax success/complete handler doesn't decrease jQuery.active bug undecided ajax 1.4.2

Reported by salomvary, 4 years ago.

Description

Test case: jQuery.ajax({url:'/', complete: function() {thisWillFail()}})

After the request is complete, jQuery.active will still equal to 1. This will cause "ajaxStart" global event never triggered again.

#6640 complete() called twice in error condition bug undecided ajax 1.4.2

Reported by noel_bush, 4 years ago.

Description

In $.ajax(), line 5251 starts a try/catch that calls send() on the xhr. As part of the send operation, the onreadystatechange() function is called (line 5163), and in some circumstances, complete() is called (line 5214). One of these circumstances is when the server is not available. An XMLHttpRequestException with code 101 / name NETWORK_ERR is thrown, and caught by the catch clause (line 5253), which then calls complete() again.

The documentation doesn't mention that complete() might be called twice.

(All line numbers are from the (non-compressed) v1.4.2.)

#6645 Unable to set ajax Request charset header bug low ajax 1.4.2

Reported by Nepherim, 4 years ago.

Description

It appears that it is not possible to set the Ajax Request Content-Type charset. The default is UTF8, regardless of other Charset, or HTML META settings.

Ref:  http://solidgone.com/jquery/ajax_charset_test.html

#6651 Add a function to pass an object, parsing JSON if needed feature low ajax 1.4.2

Reported by Chainfire, 4 years ago.

Description

Proposal function:

$.obj = function(obj) {

return (typeof obj === "string") ? $.parseJSON(obj) : obj;

}

Can be useful when using a lot of server-generated variables and such, outputted through for example PHP's json_encode. Implementing a function as follows:

$.test = function(obj) {

obj = $.obj(obj); alert(obj.foo); alert(obj.bar);

}

One simple extra call allows functions to take both obj's or JSON data directly. Especially useful if you are mixing normal and server-generated content. Using $.obj in a call directly:

$.test($.obj(...))

Now you don't need to keep track of what is JSON and what isn't.

This is of course an easy enough function for everybody to define themselves, but I think a standard API function for this would be beneficial.

#6664 parse error from jQuery.parseJSON(data) bug ajax 1.4.2

Reported by codylindley, 4 years ago.

Description

I am getting a JSON parse error using type JSON or TEXT in an ajax request. Yehuda helped me boil it down to this.

code:

jQuery.parseJSON('{"user":"userkey","addSchoolLink":{"text":"add school","id":"addSchoolBtn"},"schools":[{"rank":1,"name":"Aame of School 43214","schoolID":"987654","location":"town, state","vote":{"text":"login to vote","url":"url here","className":"loginToVoteBtn"}},{"rank":34,"name":"Bame of School 1321","schoolID":"123456","location":"town, state","vote":{"text":"vote for this school","url":"url here","className":"voteBtn"}},{"rank":34,"name":"Bame of School 1321","schoolID":"123456","location":"town, state","vote":{"text":"html that they already voted","url":false,"className":false}}]}​​​')

For me this returns an error in every browser but FF?

#6674 GET request sends Content-Type header when data on URI bug undecided ajax 1.4.2

Reported by harbulot, 4 years ago.

Description

Hello,

The fix for ticket #4183 (between 1.3.2 and 1.4) implies that GET and HEAD ajax requests send a 'Content-Type' header when they should not, since these methods do not have a message-body. Some servers refuse GET requests with a Content-Type header.

The problem is around line 352 in src/ajax.js:

if ( s.data || origSettings && origSettings.contentType ) {
        xhr.setRequestHeader("Content-Type", s.contentType);
}

A fix could be:

if ( (s.data && type !== "GET" && type != "HEAD") || origSettings && origSettings.contentType ) {
        xhr.setRequestHeader("Content-Type", s.contentType);
}

Best wishes,

Bruno.

#6677 Missing var declarations bug undecided ajax 1.4.2

Reported by msamuel, 4 years ago.

Description

The attached diff from version 1.4.3pre shows some missing var declarations and a buggy exception handler.

It was derived by running dist/jquery.js

#6678 AJAX timeout error bug undecided ajax 1.4.2

Reported by rallu, 4 years ago.

Description

When ajax call makes timeout error it first loads error function and after that it loads success function right after error.

In success method data is empty string and xmlhttprequest.status is 0.

#6688 jQuery 1.4.2 blocks console.log bug undecided ajax 1.4.2

Reported by offwhite, 4 years ago.

Description

I have a test page running locally (Apache on OSX Snow Leopard) and I reference the following URL for jQuery.

 http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js

I make an AJAX request using $.getJSON and with the response I pass the value to console.log and it shows nothing. Below is some sample code.

$("#GetJSON").click(function(e) {

$.getJSON("api/TestJSON", null, function(response) {

console.log(response);

}); e.preventDefault();

});

Now if I change it from 1.4.2 to 1.3.2 the response is logged to the console as expected. It seems that something is overriding the console logging function in 1.4.2.

#6717 psSRAPRewriter_convert_expression(type) returning invalid argument bug ajax 1.4.2

Reported by steveworkman, 4 years ago.

Description

Using a VPN product called iLink by Cognitas, being on a VPN produces URLs in the following format:  https://proxy.domain.com/the-url-you-actually-want For example  https://webtopxeu7.domain.com/http://internal.ourdomain.com/Site/default.aspx

The issue comes when trying to use the $.ajax function from URLs like this. Attempting to reach "/Site/Segment.aspx", the error returned is "Invalid argument" taking place on line 5113 of jquery-1.4.2.js.

Stepping through with the IE8 debugger, the psSRAPRewriter populates the lURL property on line 9550 as " http://internal.ourdomain.com/Site/GET" and therefore gives an invalid response. The three (magically) inserted values are:

var requestNetworkURI = ' http://internal.ourdomain.com'; var requestBaseURI = ' http://internal.ourdomain.com/Site/'; var gatewayURI = ' https://webtopxeu7.domain.com';

#6725 Javascript error in IE7 when trying to abort an AJAX request bug undecided ajax 1.4.2

Reported by lobo235, 4 years ago.

Description

Wen calling the .abort() method on the XMLHttpRequest that is returned by the $.ajax( ) method you will get a javascript error in IE7. I have written a fix for the problematic area and I have included it below:

Original Code:

// Override the abort handler, if we can (IE doesn't allow it, but that's OK)
// Opera doesn't fire onreadystatechange at all on abort
try {
	var oldAbort = xhr.abort;
	xhr.abort = function() {
		if ( xhr ) {
			oldAbort.call( xhr );
		}

		onreadystatechange( "abort" );
	};
} catch(e) { }

Fixed Code:

// Override the abort handler, if we can (IE doesn't allow it, but that's OK)
// Opera doesn't fire onreadystatechange at all on abort
try {
	var oldAbort = xhr.abort;
	xhr.abort = function() {
		if ( xhr && typeof oldAbort == 'function' ) {
			oldAbort.call( xhr );
		}

		onreadystatechange( "abort" );
	};
} catch(e) { }
#6727 Setting context to "" in $.ajax causes error bug undecided ajax 1.4.2

Reported by meyerovb, 4 years ago.

Description

Broken: $.ajax({ context: '""' }); Works: $.ajax({ context: 'any other string' });

#6728 jQuery 1.4.2 regression in Internet Explorer XMLHttp ? bug undecided ajax 1.4.2

Reported by carpii, 4 years ago.

Description

This is an odd problem, but can be reproduced reliably (and has been by many of my users)

I cant describe it very well, so its best I supply an example file.

Summary


Clicking one of the buttons does an ajax post. All works fine in firefox.

In internet explorer 7 and 8, and jquery 1.4.2, the buttons will fail with a jQuery exception.

The exception occurs when it tries to create an XMLHTTPObject, and the error is 'object does not support this property or method)

Usually if you force a reload of the page, by holding SHIFT+refresh, oddly, the buttons will then start working.

Then go to the browser address bar, and hit enter so its basically using a cached copy, and the buttons will fail again.

The reload issue is not actually cache related that I can tell. Disabling the browser cache completely produces the same results (?!).

Reverting to jquery 1.2.6 resolves the problem (although there might be later versions which work too)

#6735 I have problems when i use the methods .ajax (post and get) and method load. bug ajax 1.4.2

Reported by jeremiasrg, 4 years ago.

Description

Hi, I'm using IE8 and i have problems when i use the methods .ajax (post and get) and load().

version 1.4.2

tks.

#6742 Memory leak in Firefox 3.x when using ajax bug undecided ajax 1.4.2

Reported by domo, 4 years ago.

Description

I've an application where I use the ajax function in jquery to query the web server every second for updated data. The memory utilization increases from around 52 MB to over 70 MB in an 1 hour.

Related to #6242. The provided solution in these ticket is not working for the FF3.6.6

#6748 xhr.status === 0 should be treated as 304 (Not Modified) only in Opera bug undecided ajax 1.4.2

Reported by benjamn, 4 years ago.

Description

Consider the boolean expression returned by httpSuccess():

    return !xhr.status && location.protocol === "file:" ||
        // Opera returns 0 when status is 304
        ( xhr.status >= 200 && xhr.status < 300 ) ||
        xhr.status === 304 || xhr.status === 1223 || xhr.status === 0;

Opera may indeed return 0 when the status should be 304, but other browsers (notably, Chrome Mac) return 0 as a result of certain errors (e.g., same-origin restrictions).

Treating xhr.status === 0 as success is a special case that should apply only in Opera. This subtle difference in behavior could be keeping folks from upgrading from 1.3.x, so it should be fixed if possible.

#6750 $.getJSON (and $.ajax) not working in IE 8 bug ajax 1.4.2

Reported by thisislobo, 4 years ago.

Description

This problem went away when I downgraded from 1.4.2 to 1.3.2 so I am guessing this is a bug.

The code is for a Facebook app at  http://apps.facebook.com/frequence-game/

The core JS file is at  http://pikadoo.com/facebook/Frequence/freq.js but there is also JS in the main HTML, which you can only see if you grant permission to Facebook app (sorry about this).

The app runs as an iFrame. It breaks on a $.getJSON function call in the setUpGame() function and fails in the bowels of jQuery. More information at  http://stackoverflow.com/questions/3154273/getjson-jquery-not-working-in-ie-8

#6751 empty url on POST request ends up in Failure (SSL/Firefox) bug ajax 1.4.2

Reported by Zergling, 4 years ago.

Description

I get an error when sending a post request with an empty URL (with SSL on Firefox):


uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXMLHttpRequest.open]" nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)" location: "JS frame ::  https://***/js/jquery/jquery.js?r=9e217540984a2c8f6fff14f145f0c526 :: anonymous :: line 5113" data: no] Line 0


Line 5113 is:


Open the socket Passing null username, generates a login popup on Opera (#2865) if ( s.username ) {

xhr.open(type, s.url, s.async, s.username, s.password);

} else {

xhr.open(type, s.url, s.async); 5113

}


type = "POST" s.url = "" s.async = true

This should probably throw an exception or use location.href?

Trigger:


<form action="" onsubmit="return myFunc(this)">


myFunc(form) {

var params = $(form).serialize(); $.post(form.action, params, function(response) {

LAD.modal.respond(response, form);

});

}


#6756 Attempting to send an element as POST value hangs browser. bug ajax 1.4.2

Reported by danielsamuels, 4 years ago.

Description

Select a different value from the dropdown, the browser should hang or crash.

 http://jquery.posixx.co.uk/chrome_select.htm

#6757 Attempting to send an element as POST value hangs browser. bug undecided ajax 1.4.2

Reported by danielsamuels, 4 years ago.

Description

Select a different value from the dropdown, the browser should hang or crash.

 http://jquery.posixx.co.uk/chrome_select.htm

#6759 ajax GET error , bug ajax 1.4.2

Reported by parsturk, 4 years ago.

Description

my english bad ajax GET problem editing down code succsec okey ready

gs:{url:location.href, global:true,type:"GET",contentType:"application/x-www-form-urlencoded;", processData:true, async:true,

xhr:A#XMLHttpRequest && #A#lo#ation#protocol!=="file:"
!A.ActiveXObject#?function##{

try{return new A.XMLHttpRequest}catch#a#{return new A.ActiveXObject#"Microsoft.XMLHTTP"#} }:function##{ try{

return new A.ActiveXObject#"Microsoft.XMLHTTP"#

}catch#a#{}}, thanks

#6771 Quality factors for content negotiation bug undecided ajax 1.4.2

Reported by heungsub, 4 years ago.

Description

It is not standard implementation that making up accept header as Accept: application/json, text/javascript, */* when 'dataType' is 'json'.

Apache servers automatically add 'q=0.01' to after of '*/*'(wildcard), but the others(eg. wsgi containers) don't. For that reason, the others suffer to wrong content negotiation(container returns the 'text/html' results even I requested as 'json').

#6795 ajaxSetup and context bug ajax 1.4.2

Reported by egailis, 4 years ago.

Description

incorrect setup of context property with ajaxSetup function

line #4979

callbackContext = origSettings && origSettings.context
s,

please, fix with

callbackContext = origSettings && origSettings.context
s.context s,
#6797 FireFox 4 Beta - getScript bug ajax 1.4.2

Reported by theduke, 4 years ago.

Description

On the current Firefox 4 Beta release:

Calling $.getScript() will load the script just fine, but the callback function is not called.

#6802 IE Memory leak with ajax bug undecided ajax 1.4.2

Reported by pascal, 4 years ago.

Description

When I test the code below, i have a memory leak with IE8 (350 KB / 10 min). The file heure.php is a simple 'echo date("d/m/Y - H:i:s");'

<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 TransitionalEN" " http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns=" http://www.w3.org/1999/xhtml" xml:lang="fr" >

<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /> <script type="text/javascript" src="js/jquery-1.4.2.js"></script>

<script type="text/javascript">

function Heure(){

$.post(

'heure.php', {action: "test"}, function(data) {

document.getElementById("test").innerHTML = data;

}, "text"

);

} setInterval(Heure, 1000);

</script>

</head>

<body>

<div id="test" ></div>

</body>

</html>

#6805 RegExp test inside jQuery.parseJSON returns false positives bug ajax 1.4.2

Reported by ngiesen, 4 years ago.

Description

Objects and arrays with trailing comma's are let through by the testing RegExp, and even stuff like

var data = '{"foo":true,}{]';

( /[\],:{}\s]*$/.test(data.replace(/
(?:["
\/bfnrt]|u[0-9a-fA-F]{4})/g, "@")

.replace(/"["
\n\r]*"|true|false|null?\d+(?:\.\d*)?(?:[eE][+\-]?\d+)?/g, "]")

.replace(/(?:|:|,)(?:\s*\[)+/g, "")) )

yields true.

#6811 $.ajax does not respect contentType if data is blank bug undecided ajax 1.4.2

Reported by jloveridge, 4 years ago.

Description

Assume func is a valid function and service is an object such as: {"url": " http://host.domain.com/serviceUrl", "type": "POST"}. The contentType is honored when data is not an empty object, {}, if the data object is empty then the contentType gets mangled.

$.ajax({"url": service.url, "type": service.type, "dataType": "json", "data": data, "success": func, "contentType": "application/x-www-form-urlencoded"});

Instead of the request being made with the contentType of "application/x-www-form-urlencoded", as is supposed to be the default anyway, the request gets made with the following values for the Content-Type header:

Firefox 3.6.6 : "text/plain"

Safari 5.0: "application/xml"

So far I have only tested this on the Mac.

In my case this is preventing successful requests to a Java application since the application refuses to accept Content-Types other than application/x-www-form-urlencoded. The result is that my requests are denied. Using Charles Proxy and modifying the Content-Type header does allow my request to succeed.

#6820 $.ajax/$.getJSON fails (w/ error on line 4075) in IE8 bug ajax 1.4.2

Reported by ben.mosher, 4 years ago.

Description

Attached is an oversimplification of an application I'm writing to edit a database table. Much of the data that is ferried back and forth between the client and the server is in JSON form.

The initial page load requests a JSON object (normally generated dynamically--attached as setup.json) that includes an HTML table that represents the initial state of the editor. This loads all well and good in Firefox (3.6.6) and Opera (10.60), but in IE8 (under every different compatibility mode I could muster up), it fails out on line 4075 of the jQuery development 1.4.2 source.

Original code uses $.getJSON with an anonymous callback, but the test case defines the callback separately and includes a commented-out $.ajax call (which also fails in IE8, same error).

Not sure what to do here. Found some similar tickets, but with horrific, long, convoluted test cases. Did my best to keep it simple for this one. Apologies that the "form" property of the JSON is rather long, but that could be part of the problem. (Verified with jsonlint.com, too.)

#6829 get failure with non standard domain/port bug undecided ajax 1.4.2

Reported by paulwratt, 4 years ago.

Description

$.get(' http://192.168.1.212:2222/some/folder/'), null, function(data){_code_}); doing a remote GET (as above) in the latest jQuery causes an error when the server has no name, just IP address, and non standard port ( http://192.168.1.212:2222/)

It may not be the IP address, but the port.

It may also be present in older versions, I have not checked. (1.4.2 dev version was used)

If this can not be reproduced, I can supply other information as required.

The same code used on a "regular url" failed when moved to a url as described above. jquery was tried as remote server include, and as local server include, with the same result.

Paul

#6864 Failed CORS requests report status success due to xhr.status === 0 bug ajax 1.4.2

Reported by friedcell, 4 years ago.

Description

CORS requests in Gecko/Webkit that fail (due to absent header on the response) report status 0. Due to an Opera 9.5 workaround jQuery will deem them successful and trigger success handlers with empty data.

Currently the workaround is to know when you're making a CORS request and check xhr.status yourself and ignoring Opera, but that doesn't seem like a proper solution...

#6871 Sending FormData with file fields set wrong content-type header enhancement ajax 1.4.2

Reported by tchak, 4 years ago.

Description

Sending FormData with file fields shuld result in content-type "multipart/form-data". JQuery set it to "application/x-www-form-urlencoded" which is wrong. content-type header should be left alone in such cases so xhr object will set it to a proper "multipart/form-data" + proper boundary, by him self.

FormData is experimental stuff so I dont care if it is not supported. The real problem here is ther is no way to say to jquery to not set content-type header.

I am refering to this :

if ( s.data || origSettings && origSettings.contentType ) {
  xhr.setRequestHeader("Content-Type", s.contentType);
}

As long as there is some data to send jquery will set something in Content-Type, this is good, but there should be a way to override this...

When I am talking about FormData I refere to this :  FormData

#6873 Incorrect cross-site XHR detecting bug undecided ajax 1.4.2

Reported by oryol, 4 years ago.

Description

Following code may work incorrect for default (80) http port: var parts = rurl.exec( s.url ),

remote = parts && (parts[1] && parts[1] !== location.protocol
parts[2] !== location.host);

For example IE9 (Preview 4) returns default port in window.location.host (for example - 'localhost:80'). Even more - if we send XHR to ' http://some-host:80/some-path', then jQuery will detect it as remote query (which is wrong).

We need to check for both hosts (parts[2] and location.host) that them contains (or not) port. If not - add default 80.

(more results for this group on next page)
1 2 3 4 5 6 7 8
Note: See TracQuery for help on using queries.